Rails 4.2.0 beta1: Does Oracle enhanced adapter support it?

Rails 4.2.0 beta1 has been announced. Some of you who love new thing might have already tried it and got erros reported here.

So far Oracle enhanced adapter has been doing Rails version support from 2.3 to 3.2 by version 1.4 and lower, 4.0 and 4.1 by version 1.5. To support Rails 4.2, A new branch rails42 is created and some changes made, actually it is behind to support Rails 4.2.0 beta1. Decisions have not made if version 1.5.x suppors Rails 4.2 or bump up version just to support Rails 4.2 yet.

I did some investigation and found which rails commit we need to support. I'll open some issues and will try to address them. If you are interested in supporting Rails 4.2 with Oracle enhanced adapter, it is very welcomed to open pull requests.

Updated on Aug 26:
Rails4.2 forced_column_type not working has been opened.